External images preview outage

Incident Report for Zulip Cloud

Resolved

This incident has been resolved.
Posted May 21, 2026 - 19:19 UTC

Identified

We have identified that we are failing to serve previews of external images linked from Zulip messages.
Posted May 21, 2026 - 18:43 UTC
This incident affected: Zulip Cloud.