Some Apple push notifications were not sent

Incident Report for Zulip Cloud

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 15:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2025 - 15:20 UTC

Identified

A very small minority of Apple push notifications failed to be delivered since Aug 13 at 03:04 UTC; overall, this was 0.04% of notifications which were affected.
Posted Aug 14, 2025 - 14:16 UTC
This incident affected: Mobile Push Notification Service.